gnome sound recorder non "recorda"

1 risposta [Ultimo messaggio]
Ritratto di granger75
granger75
(Junior)
Offline
Junior
Iscritto: 18/03/2012
Messaggi: 6

Salve a tutti!
Ho cercato un po' ovunque ma non ho trovato risposta al problema:
gnome-sound-recorder su mageia2 beta 3 ha il menu a tendina "registra come" vuoto e non permette di registrare nulla.
Se si va su File/Apri "Regolazione Volume", inoltre, compare un messaggio che dice che gnome-volume-control non è installato.
La versione è la 2.91.2: a quanto sembra, la più recente.
Pare che 'sta faccenda vada avanti da un po', a vedere tutti i thread che ci sono in giro: c'è chi dice che vada installato gstreamer0.10-gconf2 (che non è nei repository), chi dice che che gnome-volume-control doveva trovarsi ancora in gnome-media (e non c'è più), chi dice che il "baco" è stato risolto nell'ultima versione (e non sembra...).
Il problema non è solamente di Mageia, ma mi chiedevo se qualcuno avesse trovato una soluzione.
Il pc in questione è l'extensa5220 in firma, la scheda audio funziona correttamente (HDA Intel - Realtek ALC268) e con Audacity si registra tranquillamente.
Grazie a tutti!

Asus P5LD2, E6300, 4GbRam, G210, 2010.2-64, 3.1.6-nrj.69mib, KDE445 - Abit Ni8-SLI-GR, P4 2.80, 4GbRam, Gf7300, 2009.1-32, 2,6,31,5-1, XFCE4 - Extensa 5220, MGA2b3, 3.3.6-desktop-1.mga2, KDE482 - AspireOne A110, 2010.2-32, 3.1.5-desktop.69mib, XFCE4 -
Presario 725EA(!), 2008.1-32, 2.6.24.7-586, KDE359 - Windows Free -

Ritratto di granger75
granger75
(Junior)
Offline
Junior
Iscritto: 18/03/2012
Messaggi: 6

Dopo aver googolato ancora un po', ho trovato che al momento l'unica soluzione sembra essere effettuare il downgrade alla versione 2.32 di gnome-media presente in Mageia 1.
Per far questo ( oltre a dare un rpm -e gnome-media --nodeps ) bisogna anche installare libgnome-media0 preso sempre dai repositories della mga1.
Questi due pacchetti si tirano dietro come dipendenze anche:
gstreamer0.10-speex
lib64canberra-gtk0
lib64unique1.0_0.
Disinstallando la versione 2.91 di gnome-media esce questo errore:

I/O warning : failed to load external entity "/etc/gconf/schemas/gnome-audio-profiles.schemas"
Apertura di "/etc/gconf/schemas/gnome-audio-profiles.schemas" non riuscita: File o directory non esistente

Se si riinstalla la 2.91 DOPO il downgrade, gnome-sound-recorder sembra andare, ma non trova più gnome-volume-control.
QUINDI: il problema sembra essere risolto dalle dipendenze che si tira dietro la 2.32, ma poiché la 2.91 ricancella gnome-volume-control, tanto vale rimanere con la 2.32.
In attesa di una soluzione più elegante, ciao a tutti!

Asus P5LD2, E6300, 4GbRam, G210, 2010.2-64, 3.1.6-nrj.69mib, KDE445 - Abit Ni8-SLI-GR, P4 2.80, 4GbRam, Gf7300, 2009.1-32, 2,6,31,5-1, XFCE4 - Extensa 5220, MGA2b3, 3.3.6-desktop-1.mga2, KDE482 - AspireOne A110, 2010.2-32, 3.1.5-desktop.69mib, XFCE4 -
Presario 725EA(!), 2008.1-32, 2.6.24.7-586, KDE359 - Windows Free -