ibus immissione testo in giapponese

2 risposte [Ultimo messaggio]
Ritratto di wowdar
wowdar
(Junior)
Offline
Junior
Iscritto: 01/09/2011
Messaggi: 39

Ho appena installato la MAGEIA 3 e avendo bisogno di scrivere in Giapponese come al solito installo ibus che con la mageia 2 funzionava perfettamente mentre ora non funziona quando lancio ibus-setup ottengo questo
[dario@localhost ~]$ ibus-daemon --xim &
[1] 5781
[dario@localhost ~]$ ibus-setup
Fontconfig warning: "/etc/fonts/conf.d/50-user.conf", line 9: reading configurations from ~/.fonts.conf is deprecated.

(main.py:5831): IBUS-WARNING **: org.freedesktop.IBus.Config.GetValue: GDBus.Error:org.freedesktop.DBus.Error.Failed: Config value [general/hotkey:triggers] does not exist.

La finestra di gestione ottengo questo


Non riesco ad usare anthy engine

Ritratto di killer1987
killer1987
(Webmaster)
Offline
Webmaster
Iscritto: 02/05/2011
Messaggi: 671

ciao, è sicuramente un bug... ti conviene segnalarlo su http://bugs.mageia.org/, solitamente questi bug vengono risolti abbastanza presto... facci sapere

ciao
Marcello

Alé Mageia, C'mon Mageia!!! SAMSUNG RC530, Nvidia GM5400, stamp HP Laserjet 1018, scanner Epson Perfection 3490

Ritratto di wowdar
wowdar
(Junior)
Offline
Junior
Iscritto: 01/09/2011
Messaggi: 39

Dopo dura lotta sono riuscito a risolvere, di seguito breve riassunto sperando che potrebbe essere utile.
Installato
ibus-gtk
ibus-gtk3
ibus-ui-gtk3

Deinstallato
ibus-qt4 (probabilmente dava qualche conflitto)

ho modificato il file .bashrc nella Home
inserendo le seguenti righe
ibus-daemon --xim&
export GTK_IM_MODULE=ibus
export XMODIFIERS=@im=ibus
export QT_IM_MODULE=ibus

Ora finalmente tutto sembra funzionare.
L'unica cosa che inserendo il comando
ibus-daemon --xim& nel file .bashrc all'avvio mi apre anche konsole, certamente male minore ma se qualcuno sa come risolvere questa cosuccia sarebbe magnifico