Aggiornamento

4 risposte [Ultimo messaggio]
Ritratto di Sandro kensan
Sandro kensan
(Geek)
Offline
Geek
Iscritto: 26/09/2012
Messaggi: 71

In questi giorni mi è stato proposto di aggiornare mageia3 e dopo alcune difficoltà ho visto che i files:

texlive-texmf - The TeX formatting system​
texlive - The TeX formatting system​

mi vengono proposti come da aggiornare. Ho visto che non sono installati sulla mia mageia3 e quindi mi chiedo come mai vuole aggiornare dei pacchetti che non sono installati. Ho provato a deselezionare questi pacchetti e a fare l'aggiornamento ma tenta comunque di scaricarli e di installarli: c'è qualche cosa che non capisco?

I pacchetti sono molto grossi e tra l'altro non ho abbastanza spazio sulla root per l'installazione, mi dispiace fare un resize della partizione in quanto è sempre una operazione rischiosa.

Il mio sito: www.kensan.it - Utente di Mageia 5/6
La mia email pubblica:
Scanner perfettamente compatibile: HP scanjet 3500c

Ritratto di killer1987
killer1987
(Webmaster)
Offline
Webmaster
Iscritto: 02/05/2011
Messaggi: 667

ciao sandro,

c'è un bug segnalato nel 2011 che è stato chiuso come invalido, potresti riaprirlo (o crearne uno nuovo per mageia 3):

https://bugs.mageia.org/show_bug.cgi?id=265

ciao,
Marcello

Alé Mageia, C'mon Mageia!!! SAMSUNG RC530, Nvidia GM5400, stamp HP Laserjet 1018, scanner Epson Perfection 3490

Ritratto di Sandro kensan
Sandro kensan
(Geek)
Offline
Geek
Iscritto: 26/09/2012
Messaggi: 71

Grazie Marcello,
il bug indica alcune cose interessanti tra cui io fatto che i due pacchetti che ho segnalato possono benissimo essere delle dipendenze di altri pacchetti. Nel 2011 erano dipendente di tetex, adesso possono essere dipendenze di altri pacchetti.

Mi pare strano che un aggiornamento richieda l'installazione di nuovi pacchetti ma può essere. Quel che non mi spiego è come mai nell'aggiornamento non è efficace la deselezione dei due pacchetti texlive e texlive-texmf in quanto li vuole installare anche se sono deselezionati: che sia un bug?

Il mio sito: www.kensan.it - Utente di Mageia 5/6
La mia email pubblica:
Scanner perfettamente compatibile: HP scanjet 3500c

Ritratto di killer1987
killer1987
(Webmaster)
Offline
Webmaster
Iscritto: 02/05/2011
Messaggi: 667

beh, potrebbero essere delle nuove dipendenze di un pacchetto da aggiornare oppure potrebbe essere stato fatto un errore da parte dei packager... io prima controllerei se altri pacchetti che stai aggiornando li richiedono e se effettivamente sono necessari... se anche se vengono richiesti non servono potrebbe essere un bug e potresti commentare il bug già segnalato... fammi sapere

ciao
Marcello

Alé Mageia, C'mon Mageia!!! SAMSUNG RC530, Nvidia GM5400, stamp HP Laserjet 1018, scanner Epson Perfection 3490

Ritratto di Sandro kensan
Sandro kensan
(Geek)
Offline
Geek
Iscritto: 26/09/2012
Messaggi: 71

Ho aspettato fino ad aggi per aggiornare mageia e oggi mi accorgo che i due pacchetti sono scomparsi dalla lista degli aggiornamenti: era un bug? non so comunque sono riuscito ad aggiornare mageia3.

Il mio sito: www.kensan.it - Utente di Mageia 5/6
La mia email pubblica:
Scanner perfettamente compatibile: HP scanjet 3500c