Mageia 4 - beta 2 x86_64 iso -impossibile installarla.

6 risposte [Ultimo messaggio]
Ritratto di nonnogs
nonnogs
(Junior)
Offline
Junior
Iscritto: 16/02/2012
Messaggi: 16

Ciao a tutti.A suo tempo scaricai e tentai di installare la beta2 ma immediatamente dopo l'apertura si bloccava ed era impossibile andare avanti.Immaginai che si trattasse di un bug,così lasciai correre la beta in attesa della final release che ormai è alle porte.Ieri invece ci sono tornato sopra ed ho scaricato ed installato -a buon fine- la liveDVD (1,6 Gb).Premetto che uso un vecchio desktop con disco di 500 Gb e in quei 500 ho infilato dieci dodici OS.Che però Mageia non mi permette di vedere.Al boot c'è mageia(couldron) e una sfilza di voci che però non corrispondono a quasi niente.Urpmi mi dice che os-prober è già installato -Mageia è già aggiornata ed i supporti li ho installati subito-,update-grub mi legge tutti gli OS installati ma al riavvio trovo la situazione di origine.C'è qualche altra strada per avere un boot completo?
Vi saluto.

Faboski
[=small]L'utopia non e' l'irrealizzabile ma l'irrealizzato[/]

Ritratto di killer1987
killer1987
(Webmaster)
Offline
Webmaster
Iscritto: 02/05/2011
Messaggi: 668

ciao,

stai usando grub 1? hai provato ad usare il 2 (o viceversa)? fammi sapere

ciao
Marcello

Alé Mageia, C'mon Mageia!!! SAMSUNG RC530, Nvidia GM5400, stamp HP Laserjet 1018, scanner Epson Perfection 3490

Ritratto di nonnogs
nonnogs
(Junior)
Offline
Junior
Iscritto: 16/02/2012
Messaggi: 16

killer1987 ha scritto:

ciao,

stai usando grub 1? hai provato ad usare il 2 (o viceversa)? fammi sapere

ciao
Marcello

Ciao Killer1987

nelle note di rilascio alla voce GRUB ho trovato questa notazione :

Mageia 4 beta 2 still comes with GRUB as a default.But we also provide GRUB2.

Sembrerebbe quindi che stia usando GRUB e non GRUB2.Non conosco il modo per esserne certo.Provo ad installare GRUB2 e dopo ti faccio sapere.
Ciao grazie.giorgio scubla.

Aggiungo : il terminale mi dice : il pacchetto grub2-2.00-58.mga4-x86_64 è già installato
edè quindi presumibile che venga usato.Non sei d'accordo?

No,sono andato avanti con la ricerca e il terminale mi dice ancora :

[root@localhost giorgio]# grub-install -v
grub-install (GNU GRUB 0.97)

è quindi il vecchio GRUB.

Faboski
[=small]L'utopia non e' l'irrealizzabile ma l'irrealizzato[/]

Ritratto di killer1987
killer1987
(Webmaster)
Offline
Webmaster
Iscritto: 02/05/2011
Messaggi: 668

prima di usare grub2 proviamo un'altra strada... installa os-prober e poi ripeti la procedura con update-grub... non ho mai avuto problemi con grub, se non risolvi chiedo nella mailing list e li sicuro mi daranno le dritte giuste... fammi sapere

ciao
Marcello

Alé Mageia, C'mon Mageia!!! SAMSUNG RC530, Nvidia GM5400, stamp HP Laserjet 1018, scanner Epson Perfection 3490

Ritratto di nonnogs
nonnogs
(Junior)
Offline
Junior
Iscritto: 16/02/2012
Messaggi: 16

killer1987 ha scritto:

prima di usare grub2 proviamo un'altra strada... installa os-prober e poi ripeti la procedura con update-grub... non ho mai avuto problemi con grub, se non risolvi chiedo nella mailing list e li sicuro mi daranno le dritte giuste... fammi sapere

ciao
Marcello

 
[root@localhost giorgio]# urpmi os-prober
Il pacchetto os-prober-1.63-2.mga4.x86_64 è già installato
[root@localhost giorgio]# update-grub
Creazione di grub.cfg...
Tema trovato: /boot/grub2/themes/maggy/theme.txt
Trovata immagine linux: /boot/vmlinuz-desktop
Trovata immagine initrd: /boot/initrd-desktop.img
Trovata immagine linux: /boot/vmlinuz-3.12.6-desktop-5.mga4
Trovata immagine initrd: /boot/initrd-3.12.6-desktop-5.mga4.img
Trovata immagine linux: /boot/vmlinuz-3.12.6-desktop-4.mga4
Trovata immagine initrd: /boot/initrd-3.12.6-desktop-4.mga4.img
Trovata immagine linux: /boot/vmlinuz-3.12.3-desktop-1.mga4
Trovata immagine initrd: /boot/initrd-3.12.3-desktop-1.mga4.img
Trovato Debian GNU/Linux (7.0) su /dev/sda1
Trovato Manjaro Linux (0.8.8) su /dev/sda11
Trovato Ultimate Edition 3.8 (3.8) su /dev/sda13
Trovato Slackware Linux (Slackware 14.1) su /dev/sda2
Trovato Manjaro Linux (0.8.9-pre1) su /dev/sda3
Trovato Ubuntu 13.10 (13.10) su /dev/sda6
Trovato Gentoo Base System release 2.1 su /dev/sda7
Trovato OpenMandriva Lx 2013.0 (2013.0) su /dev/sda8
Trovato openSUSE 12.3 (i586) su /dev/sda9
fatto
[root@localhost giorgio]#

Ma il booting è sempre lo stesso.Ciao.

Faboski
[=small]L'utopia non e' l'irrealizzabile ma l'irrealizzato[/]

Ritratto di killer1987
killer1987
(Webmaster)
Offline
Webmaster
Iscritto: 02/05/2011
Messaggi: 668

ho proprio l'impressione che sia un bug allora. se hai aggiornato il sistema con gli ultimi updates e non riesci comunque a risolvere ti conviene segnalare il bug su:

http://bugs.mageia.org/

se non conosci l'inglese ti posso dare una mano io... fammi sapere

ciao
Marcello

Alé Mageia, C'mon Mageia!!! SAMSUNG RC530, Nvidia GM5400, stamp HP Laserjet 1018, scanner Epson Perfection 3490

Ritratto di nonnogs
nonnogs
(Junior)
Offline
Junior
Iscritto: 16/02/2012
Messaggi: 16

Ciao Marcello ho tentato anche con grub-customizer ma ho scancherato tutto.Alla fine mi sono deciso a sovrascrivere Mageia4 -2 ed aspettare che esca la final release.Ti ringrazio,l'inglese lo conosco abbastanza da leggerlo e meno scriverlo ma ormai ho deciso e vado avanto così.Ci risentiamo a febbraio,ormai manca poco.Quello che mi meraviglia è che in genere la RC2 è quasi sempre completa abbastanza.Invece Mageia....
Ci rivediamo Marcello.Intanto ti ringrazio dell'aiuto che mi hai dato.
Ciao grazie.

Faboski
[=small]L'utopia non e' l'irrealizzabile ma l'irrealizzato[/]