Schermo nero dopo update

7 risposte [Ultimo messaggio]
Ritratto di Sandro kensan
Sandro kensan
(Geek)
Offline
Geek
Iscritto: 26/09/2012
Messaggi: 69

Ciao a tutti,
dopo un update automatico di mageia 4 mi ritrovo con lo schermo nero dopo il boot.
Anche aspettando un minuto non sento la musichetta dell'entrata nella mia sessione utente e anche la tastiera non si illumina segno che il pc non arriva mai alla fase di autologin.

Per questo penso che non si tratti di semplici problemi di driver grafici ma si tratti del fatto che il sistema non parta. Adesso mageia parte con il penultimo kernel e tutto fila liscio ma se metto l'ultimo ho i problemi descritti.

Killer o altri hanno qualche dritta da darmi?

Grazie in anticipo.

Ritratto di killer1987
killer1987
(Webmaster)
Offline
Webmaster
Iscritto: 02/05/2011
Messaggi: 642

ciao sandro,

se con il penultimo kernel va tutto liscio mentre con l'ultimo si blocca il sistema probabilmente è un bug upstream o di qualche patch aggiunta dal team mageia... dovresti segnalare il bug a mageia, per problemi di questo tipo si impegnano parecchio a risolverli... fai sapere

ciao
Marcello

Alé Mageia, C'mon Mageia!!! SAMSUNG RC530, Nvidia GM5400, stamp HP Laserjet 1018, scanner Epson Perfection 3490

Ritratto di Sandro kensan
Sandro kensan
(Geek)
Offline
Geek
Iscritto: 26/09/2012
Messaggi: 69

killer1987 ha scritto:

ciao sandro,

se con il penultimo kernel va tutto liscio mentre con l'ultimo si blocca il sistema probabilmente è un bug upstream o di qualche patch aggiunta dal team mageia... dovresti segnalare il bug a mageia, per problemi di questo tipo si impegnano parecchio a risolverli... fai sapere

Grazie Marcello per la risposta, volevo chiederti come si fa ad aggiungere qualche info in più in modo da essere maggiormente incisivi nella segnalazione di un bug rispetto a aquella che ho fatto io:

https://bugs.mageia.org/show_bug.cgi?id=13884

Parlano della failsafe ma cosa devo selezionare all'avvio per andare in failsafe? Ho provato Mageia (failsafe) ma vado dopo una serie di linee tipo quelle che ci sono in dmesg mi mostra un prompt e la tastiera risulta bloccata (ho qualche fail).

Ritratto di killer1987
killer1987
(Webmaster)
Offline
Webmaster
Iscritto: 02/05/2011
Messaggi: 642

per avviare in failsafe quando grub ti permette di scegliere il sistema da avviare devi selezionare altre opzioni (o qualcosa di simile) e nei parametri rimuovere tutto il resto e mettere

splash quiet failsafe

e avvii. il failsafe attiva solo i servizi essenziali (in modalità testuale) per cui può essere utile per capire quale problema ti stia bloccando il sistema. fammi sapere

ciao
Marcello

Alé Mageia, C'mon Mageia!!! SAMSUNG RC530, Nvidia GM5400, stamp HP Laserjet 1018, scanner Epson Perfection 3490

Ritratto di Sandro kensan
Sandro kensan
(Geek)
Offline
Geek
Iscritto: 26/09/2012
Messaggi: 69

killer1987 ha scritto:

splash quiet failsafe

Io nella lista dei paramentri ho anche il kernel, il parametro root, resume e vga, che faccio con questi?

Ritratto di killer1987
killer1987
(Webmaster)
Offline
Webmaster
Iscritto: 02/05/2011
Messaggi: 642

il parametro del kernel prova a lasciarlo, gli altri li puoi togliere... ti ricordo che i parametri da dare al sistema all'avvio sono temporanei se fatti all'avvio di grub per cui puoi fare piu prove o cercare parametri alternativi in internet.. fammi sapere

ciao
Marcello

Alé Mageia, C'mon Mageia!!! SAMSUNG RC530, Nvidia GM5400, stamp HP Laserjet 1018, scanner Epson Perfection 3490

Ritratto di Sandro kensan
Sandro kensan
(Geek)
Offline
Geek
Iscritto: 26/09/2012
Messaggi: 69

Dopo un anno ho risolto il problema, lo scrivo qui così nessuno pensi che con mageia i problemi rimangano insoluti. Thomas, un pezzo grosso della comunità mageia internazionale mi ha seguito e mi ha indicato di togliere splash quiet e così facendo ho potuto vedere l'errore che veniva generato nella fase di boot appena dopo grub. A dire la verità c'ero arrivato da solo e Thomas me lo ha suggerito mezz'ora dopo che l'ho capito.

Si tratta dell'abc che io da buon autodidatta linux non sapevo, un buco nelle mie conoscenza, togliere splash quiet nella stringa di boot del kernel.

Poi Thomas mi ha seguito e mi ha indicato quale fosse il mio problema relativo al punto di freeze del mio sistema:
fb: conflicting fb hw usage radeondrmfb vs VESA VGA - removing generic driver

Thomas mi ha indicato la soluzione:

Citazione:

ok, so you are missing the nonfree radeon firmware.

Ensure you have the "Nonfree Updates" media enabled, and install radeon-firmware-20140828-1.mga4

it should automatically regenerate the initrds with the needed firmware.

after that, try to boot again with the new 3.14.39 kernel

Come detto da Thomas Backlund il problema era che non avevo il firmware radeon installato.

Installato il firmware i problemi sono scomparsi e ho potuto avere un pc che funziona.

Ho poi provveduto a mettere come default la prima voce che richiama vmlinuz nel boot di grub la quale si occupa di richiamare l'ultima voce della lista menu.lst ovvero l'ultimo kernel installato ovvero il più recente.

Detto questo ho offerto 10 euro per comprarsi il caffè a Thomas che ha rifiutato e mi ha invitato a fare una donazione a mageia, piccola donazione in bitcoin fatta!

Questo il link dove è descritto il bug:

https://bugs.mageia.org/show_bug.cgi?id=14379

Ritratto di killer1987
killer1987
(Webmaster)
Offline
Webmaster
Iscritto: 02/05/2011
Messaggi: 642

ottima notizia, grazie per aver spiegato anche qua come hai fatto a risolvere il problema.. si, tutta la comunità è disponibilissima a dare una mano, anche questo è uno dei punti forti di Mageia Wink a presto

ciao
Marcello

Alé Mageia, C'mon Mageia!!! SAMSUNG RC530, Nvidia GM5400, stamp HP Laserjet 1018, scanner Epson Perfection 3490