Bande colorate con lo scanner Epson Perfection 1250

Nessuna risposta
Ritratto di Sandro kensan
Sandro kensan
(Geek)
Offline
Geek
Iscritto: 26/09/2012
Messaggi: 71

Lo scanner Epson perfection 1250 in mio possesso fa scansioni che spesso presentano due bande colorate: una a destra e una a sinistra. Il problema si presenta da molti anni a questa parte e riguarda le versioni a 64 bit del backend plustek.

In fondo a questo articolo si possono trovare i riferimenti e la soluzione:
http://www.kensan.it/articoli/iScan_how_to.php

In particolare si dice:

Citazione:

Color error with Epson Perfection 1250.

Hello:

I use Ubuntu 10.04 and an Epson Perfection 1250 scanner. I'm experiencing a weird problem which is related to colours.

Regardless I use Simple Scan or XSane, after doing at least 1 scan (complete or partial) or a few previews, the programs start to act goofy and show a wrong colour composition:

Oppure si dice:

Citazione:


Epson Perfection 1250 Scanner Color Banding

Postby andy17mb on Thu Jun 26, 2014 7:00 am
Hi All,

I'm having scanning issues... I'm using Mint 17 Cinnamon 64bit and have libsane 1.0.23-3ubuntu3.1 installed. I've tried scanning with Simple scan, XSane and Gscan2pdf (so the Sane backend - plustek:libusb:004 for my Epson Perfection 1250 - is the same) and intermittently I am getting colour tinted scans when i scan in colour (eg left half of the image is green tinted and right half is red tinted or wholly yellow or pink background).

Oppure:

Citazione:

> Scanning several pages with my flatbed scanner works fine for the first
> two pages; the subsequent pages will have wide coloured vertical bands
> in the background (black for a grayscale scan).
>
> This is true for the 64-bit versions of Fedora 16, 17 and 18; with the
> 32-bit versions of the mentioned distributions there is no problem.
> Scanning using xsane or simple-scan produce both the misbehaviour.

La soluzione indicata nel primo link qui sopra è quella di modificare il parametro altCalibration da 0 a 1 e il problema sparisce, comunque speriamo in una riscrittura delle parti di codice che funzionano male sotto i 64 bit.

Infatti il problema è ampio come indicato nella lista di bug di seguito:

Citazione:

314021 sane-find-scanner sees scanner but does not recognize it on 64 bit, works fine on 32 bit
304296 plustek: Color problem on amd64
312505 Epson Perfection 1250 works but, after 1-3 scans, it shows 2 vertical bands of different tones.
314019 my scanner has a problem in the 64-bit systems but works fine with the same systems in 32 bit

Maybe same class:
313712 Different colors on the right and the left half of the scan

The Plustek Backend (maybe U12 and plustek_pp) needs to be revised to get rid of the assumption u_long/long data types are only 32 bits wide.

Solution:
Change from 0 to 1 the parameter altCalibration in /etc/sane.d/plustek.conf

Il mio sito: www.kensan.it - Utente di Mageia 5/6
La mia email pubblica:
Scanner perfettamente compatibile: HP scanjet 3500c