amarok

3 risposte [Ultimo messaggio]
Ritratto di astrofilo
astrofilo
(Junior)
Offline
Junior
Iscritto: 17/08/2012
Messaggi: 22

provando a installare amarok 2.8.0 da sorgenti mi dice che manca queesto pacchetto gmock (1.4 or higher)
Used in Amarok's tests. Dove l'ho trovo? grazie

Ritratto di killer1987
killer1987
(Webmaster)
Offline
Webmaster
Iscritto: 02/05/2011
Messaggi: 663

ciao,

ho guardato sia le istruzioni di compilazione:

http://community.kde.org/Amarok/Development/Compiling

sia la dipendenza a cui ti riferisci:

https://code.google.com/p/gmock/downloads/list

gmock è arrivato alla release 0.8 quindi è impossibile che venga richiesta quella versione... inoltre nelle istruzioni di compilazione non ne fa cenno e nelle fonti mageia non c'è nessun pacchetto di questo tipo, sebbene ci sia amarok 2.8.. sei sicuro di non aver sbagliato qualcosa? se c'è un errore non mi viene in mente su come risolverlo.. al massimo forse puoi provare a installare l'ultima versione di gmock e vedere se va..

ciao
Marcello

Alé Mageia, C'mon Mageia!!! SAMSUNG RC530, Nvidia GM5400, stamp HP Laserjet 1018, scanner Epson Perfection 3490

Ritratto di astrofilo
astrofilo
(Junior)
Offline
Junior
Iscritto: 17/08/2012
Messaggi: 22

dopo l'installazione da sorgenti quanto provo a lanciarlo mi da questo errore:$ cd /path/to/amarok/source-code/
$ su -c "make uninstall"
$ cmake -DCMAKE_INSTALL_PREFIX=`kde4-config --prefix` && su -c "make install"
$ kbuildsycoca4 --noincremental
$ amarok
a cosa puo essere dovuto? grazie

Ritratto di killer1987
killer1987
(Webmaster)
Offline
Webmaster
Iscritto: 02/05/2011
Messaggi: 663

puoi allegare sia l'output dell'installazione che dell'avvio? da konsole su File c'è Salva output come...

ciao
Marcello

Alé Mageia, C'mon Mageia!!! SAMSUNG RC530, Nvidia GM5400, stamp HP Laserjet 1018, scanner Epson Perfection 3490