Audio in disordine

12 risposte [Ultimo messaggio]
Ritratto di Bourbon
Bourbon
(Junior)
Offline
Junior
Iscritto: 13/06/2011
Messaggi: 37

Ciao a Tutti Smile

Credo che l' origine di tutti i guai sia Pulseaudio; non riesco a registrare da microfono, sia usando Audacity che Skype.
Ho installato non ricordo quanti plugins e tentato varie combinazioni sia in Pavucontrol che nel pannello di Audacity (Skype offre solo Pulseaudio), senza concludere niente.
Credo che la soluzione migliore sia disinstallare Pulseaudio, voi avete qualche idea migliore ?

Grazie per la Vs. cortese attenzione Wave

CPU: -CP-IP4P-5200 INTEL DUAL CORE E5200 2.5GHZ
HD: -SG-3S320 3.5" SATA 320GB HDD SEAGATE
Scheda video: -ZT -GF94GTY-512 ZOTAC 9400GT 512MB DDR2 PCI-E

Ritratto di francofait
francofait
(Geek)
Offline
Geek
Iscritto: 02/06/2011
Messaggi: 108

si , disabilitalo da pannello di controllo - hardware - audio , poi configuri kmix abilitando tutti i controlli, e porta i volumi al massimo

apt-get install linux – il mio blog
apt-get -- purge remove Windows
http://faitfranco.wordpress.com

Ritratto di Bourbon
Bourbon
(Junior)
Offline
Junior
Iscritto: 13/06/2011
Messaggi: 37

Ciao Franco,

Grazie per il tuo intervento, ma pare che il problema sia più serio di quanto pensassi; ho disattivato Pulseaudio e non è cambiato niente, ho installato Phonon-VLC, idem.
Adesso ho riattivato Pulseaudio con Phonon-VLC al posto di Phonon-GStreamer ed il microfono è ancora muto; da alsamixer per avere tutti i controlli, devo scegliere F6, altrimenti ne risulta uno solo (KMix ne presenta sempre uno solo).
Provato anche "alsaconf" + "alsamixer" + "alsactl store", niente Waiting

CPU: -CP-IP4P-5200 INTEL DUAL CORE E5200 2.5GHZ
HD: -SG-3S320 3.5" SATA 320GB HDD SEAGATE
Scheda video: -ZT -GF94GTY-512 ZOTAC 9400GT 512MB DDR2 PCI-E

Ritratto di luca64
luca64
(Collaboratore)
Offline
Collaboratore
Iscritto: 24/05/2011
Messaggi: 78

Ciao Silvio,

Percaso quanto hai configurato skype, non hai visto da preferenze audio se per caso ti vede 2 microfoni ? dico questo perche' una volta installando skype su linux mint non funzionava il microfono , andando in preferenze audio (Alsa quello che usa skype ) notai che vi erano 2 microfoni, mi basto' allora mettere l'altro microfono e risolsi il problema !

Ciao luca (era un notebook acer )

Ritratto di Bourbon
Bourbon
(Junior)
Offline
Junior
Iscritto: 13/06/2011
Messaggi: 37

Ciao Luca,

Skype e Pulseaudio sono alleati.... Pulseaudio è l' unica opzione di Skype e Pulseaudio tramite KMix mostra una sola colonna di controllo per tutto; per trovare il microfono, devo aprire alsamixer e devo pure premere F6 per selezionare la mia scheda.
Così facendo ottengo le colonne per il microfono frontale e per quello posteriore (che è quello che interessa a me, dato che per frontale s' intende quello incorporato nei portatili.
Credo di aver fatto tutte le prove possibili ed immaginabili, senza concludere niente, Audacity e Skype non vedono il microfono, sia con Pulseaudio disattivato che no.
Mi sono preso una pausa perchè ne ho avuto abbastanza per oggi, se in settimana trovo un momento, ci torno su.

Ciao Smile

Edit
Non voglio gridare al bug, però mi sono convinto che "manca qualcosa"; presumo che questo qualcosa verrà fuori quando saranno attivati i repositories (al momento il sistema risulta totalmente aggiornato)

CPU: -CP-IP4P-5200 INTEL DUAL CORE E5200 2.5GHZ
HD: -SG-3S320 3.5" SATA 320GB HDD SEAGATE
Scheda video: -ZT -GF94GTY-512 ZOTAC 9400GT 512MB DDR2 PCI-E

Ritratto di Big
Big
(Newbie)
Offline
Newbie
Iscritto: 22/06/2011
Messaggi: 3

Pure a me non funziona il microfono...ho provato con skype ma nulla...

Ritratto di killer1987
killer1987
(Webmaster)
Offline
Webmaster
Iscritto: 02/05/2011
Messaggi: 663

potete segnalare (in inglese) il bug qua https://bugs.mageia.org/ e darci il link per seguirlo?

ciao
Marcello

Alé Mageia, C'mon Mageia!!! SAMSUNG RC530, Nvidia GM5400, stamp HP Laserjet 1018, scanner Epson Perfection 3490

Ritratto di Bourbon
Bourbon
(Junior)
Offline
Junior
Iscritto: 13/06/2011
Messaggi: 37

Ciao Marcello,

Aspetto di vedere cosa succede quando saranno disponibili i primi aggiornamenti; non mi stupirei se la soluzione venisse fuori in questo modo Wave

CPU: -CP-IP4P-5200 INTEL DUAL CORE E5200 2.5GHZ
HD: -SG-3S320 3.5" SATA 320GB HDD SEAGATE
Scheda video: -ZT -GF94GTY-512 ZOTAC 9400GT 512MB DDR2 PCI-E

Ritratto di Bourbon
Bourbon
(Junior)
Offline
Junior
Iscritto: 13/06/2011
Messaggi: 37

killer1987 ha scritto:

potete segnalare (in inglese) il bug qua https://bugs.mageia.org/ e darci il link per seguirlo?

ciao
Marcello


Ciao Marcello,

Va bene, mi sono convinto che il bug c' è; forse in Mageia ci stanno già lavorando perchè ho visto che è stato segnalato.
L' indirizzo della segnalazione è questo: https://bugs.mageia.org/show_bug.cgi?id=1624
Già diversi utenti si sono accodati, quindi mi pare superfluo aggiungermi; il problema riguarda entrambe le architetture e non si risolve ne con le indicazioni ad oggi fornite da Andre Baer ne disattivando Pulseaudio, ne installando/preferendo il phonon VLC (anzi, con VLC la situazione peggiora) Wave

CPU: -CP-IP4P-5200 INTEL DUAL CORE E5200 2.5GHZ
HD: -SG-3S320 3.5" SATA 320GB HDD SEAGATE
Scheda video: -ZT -GF94GTY-512 ZOTAC 9400GT 512MB DDR2 PCI-E

Ritratto di killer1987
killer1987
(Webmaster)
Offline
Webmaster
Iscritto: 02/05/2011
Messaggi: 663

è sempre meglio aggiungersi e partecipare alla discussione e alla fase di debug... inoltre più persone seguoni il bug e più lo sviluppatore/maintainer si impegnerà per risolvere il problema

ciao
Marcello

Alé Mageia, C'mon Mageia!!! SAMSUNG RC530, Nvidia GM5400, stamp HP Laserjet 1018, scanner Epson Perfection 3490

Ritratto di Roberto Simone
Roberto Simone
(Junior)
Offline
Junior
Iscritto: 27/08/2011
Messaggi: 20

Anche io ho due microfoni: uno presente nella scheda audio del pc ed un altro presente nella webcam collegata.
Però i due microfoni nel mio caso sono visibili dal pannello di controllo di pulseaudio (pavucontrol), precisamente nella scheda "configurazione".
Così mi è bastato selezionare la voce "spento" per il microfono che fa parte della webcam...