Compilazione wallet criptovalute

Nessuna risposta
Ritratto di Sandro kensan
Sandro kensan
(Geek)
Offline
Geek
Iscritto: 26/09/2012
Messaggi: 71

Compilazione wallet criptovalute

=================================================================

Compilazione effettuata con successo su mageia 4, distribuzione rpm.

Per futuri riferimenti e per chi vuole compilare il darkcoin wallet (o
analoghe criptovalute) sotto Mageia o analoga distribuzione.

pacchetti da installare in Debian:

qt4-qmake
libqt4-dev
build-essential
libboost-dev
libboost-system-dev
libboost-filesystem-dev
libboost-program-options-dev
libboost-thread-dev
libssl-dev
libdb++-dev
libminiupnpc-dev

Che in mageia 64 bit diventano:

lib64db5.3-devel
rpm-build
lib64qt4-devel (qmake)
lib64miniupnpc-devel
lib64boost-devel
lib64openssl-devel

In Mageia si usa installare il pacchetto:
rpm-build
che è equivalente a build-essential per debian.

Altro problema trovato è che non trova gli header db_cxx.h e per
risolvere si usa aggiungere al INCPATH dove si trova db_cxx.h

«The only thing I've had to do is to add -I/usr/include/db4.8 at the end
of the INCPATH in the Makefile generated by qmake.»

https://github.com/dogecoin/dogecoin/issues/76

================================================

Il mio sito: www.kensan.it - Utente di Mageia 5/6
La mia email pubblica:
Scanner perfettamente compatibile: HP scanjet 3500c