Installare Firefox e il plugin flash player

Nessuna risposta
Ritratto di Sandro kensan
Sandro kensan
(Geek)
Offline
Geek
Iscritto: 26/09/2012
Messaggi: 71

Metto qui una nota per chi è nella mia stessa situazione ovvero con una distro "vecchia" e non più aggiornata e vuole avere firefox aggiornato fin quando non si deciderà a passare alla nuova versione di mageia (5 nel mio caso).

Questi sono i post che ho messo sul newsgroup it-alt.computer.software.mozilla.

Citazione:

Ok, primo metodo fallito, non è possibile copiare solo l'eseguibile
firefox occorre tutta la cartella di ff_esr, le due cartelle sono
diverse: ff scaricato è molto diverso da ff pacchettizzato nella
struttura dei file nella cartella.

ff ESR l'ho scaricato dal sito mozilla mentre ff pacchettizzato è in:
/usr/lib64/firefox-38.2.1/

Ho quindi optato per scaricare ff in ~/sandro e poi ho fatto un link
sofware tra /usr/bin/ff e l'eseguibile in $HOME. Pare funzioni bene però
mi ha detto all'avvio che non è il browser di default, quindi ci sono
impostazioni che non hanno "tenuto" e poi ho attivato l'autoapdate che
sui pacchetti non funziona, con ff su $HOME dovrebbe funzionare.

cd /usr/bin/
ln -s /home/sandro/firefox/firefox firefox

Per quanto riguarda flash ecco cosa ho fatto:

Citazione:

flash nella sua dir /usr/lib64/flash-player-plugin (libflashplayer.so) è
il plugin eseguito solo da ff pacchettizzato mentre la versione che ho
scaricato richiede i plugin in ~/.mozilla/plugin, basta mettere
libflashplayer.so scaricato da adobe.

ecco i singoli passi ordinati:

Citazione:

Firefox ESR
1) ho scaricato ff esr dal sito mozilla
2) l'ho copiato in $HOME
3) ho fatto un link software:
cd /usr/bin/
ln -s /home/sandro/firefox/firefox firefox

flash:
1) ho scaricato il pacchetto flash da adobe (il pacchetto compresso tar.gz per linux)
2) ho copiato in ~/.mozilla/plugin, il plugin
libflashplayer.so che ho scaricato al punto 1

Il mio sito: www.kensan.it - Utente di Mageia 5/6
La mia email pubblica:
Scanner perfettamente compatibile: HP scanjet 3500c