libreoffice: non parte foglio di calcolo

6 risposte [Ultimo messaggio]
Ritratto di james2221
james2221
(Junior)
Offline
Junior
Iscritto: 10/09/2012
Messaggi: 7

ciao
mageia 86_64 kde4*
buongiorno, installazione di circa 1 settimana.
Ho un minimo di esperienza Linux di 4 anni avendo già installato e lavorato con Arch Debian Slack e Sabayon (tuttora installate e funzionanti alla grande, NON ho Windows, sopperisco ai programmi obbligatori microsoft con Virtualbox).
Da un paio di giorni, pur non avendo fatto aggiornamenti, quando tento di far parire libreoffice-calc il terminale mi dicecannot execute binary file. Per farlo partire devo aprire libreoffice write e da lì mi lascia accedere al foglio di calcolo. Non riesco in altro modo, nè dal menu nè da lanciatore, nient'altro cha da libreoffice-write. Cercando sul web mi si dice che è solitamente un problema di architettura 32-64 ma io ho libreoffice64 e corretta architettura a 64 bituname -a   Linux localhost 3.3.8-desktop-2.mga2 #1 SMP Mon Jul 30 21:35:06 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux.
L'unico pacchetto che ho installatom è stato librecad, datosi che non sono riuscito a mettere giù drafsight essendo quest'ultimo a 32 bit.
Qualche maghetto all'ascolto ?
grazie
james
scusate ma non sono riuscito a far funzionare i code

Ritratto di killer1987
killer1987
(Webmaster)
Offline
Webmaster
Iscritto: 02/05/2011
Messaggi: 671

ciao e benvenuto,

il messaggio di errore è talmente generico che non serve a nulla... hai provato a rimuovere la cartella di configurazione e a rimuovere e reinstallare libreoffice?

ciao
Marcello

Alé Mageia, C'mon Mageia!!! SAMSUNG RC530, Nvidia GM5400, stamp HP Laserjet 1018, scanner Epson Perfection 3490

Ritratto di james2221
james2221
(Junior)
Offline
Junior
Iscritto: 10/09/2012
Messaggi: 7

ciao
purgato e reinstallato libreoffice, cancellato cartella .config/libreoffice, il risultato è identico.
Ti posto la riga di comando ma non dice niente di piu di quanto sopra

[piero@localhost ~]$ /mnt/Dati/DatiLavoro/AF.Elektra/Anno2010/Giornaliera.ods
bash: /mnt/Dati/DatiLavoro/AF.Elektra/Anno2010/Giornaliera.ods: cannot execute binary file
[piero@localhost ~]$

questo per un file specifico, ma la dicitura vale per tutti i file .ods. Se dò libreoffice da terminale mi si apre la schermata e posso far partire anche il foglio di calcolo. Ho provato anche a cambiare i permessi con chmod ma rien a faire. Quel che mi pare strano è che L.O.write si apra e mi permetta di far partire anche L.O.calc. E naturalmente non parte nemmeno con le icone dei lanciatori nè con il menu.

grazie

Ritratto di azioga
azioga
(Geek)
Offline
Geek
Iscritto: 27/03/2012
Messaggi: 88

con che comando lo fai partire????

prova

$ libreoffice -calc /mnt/Dati/DatiLavoro/AF.Elektra/Anno2010/Giornaliera.ods

ciao, Luca.

Ritratto di james2221
james2221
(Junior)
Offline
Junior
Iscritto: 10/09/2012
Messaggi: 7

scusa ho sbagliato a fare copia incolla:

[piero@localhost ~]$ libreoffice /mnt/Dati/DatiLavoro/AF.Elektra/Anno2010/Giornaliera.ods: cannot execute binary file
[piero@localhost ~]$

lo fa solo con .ods, i file .odt vanno bene.
Da altre distro nessun problema, e comunque da icona lanciatore e icona menu i file .odt non si aprono.

ho cancellato dei pacchetti orfani il primo giorno che ho installato la distro sabato 10 gg fa, in fase di "costruzione" ma erano tutti file inerenti a clementine che ho installato e poi sostituito con amarok. Non vorrei aver fatto paosticci con i repository, attualmente ho core release, core updates, core backport e non-free. Se avessi installato libreoffice con i repository tainted che poi ho disabilitato? potrebbe essere un problema esistente fin dall'inizio, nel senso che ho cominciato solo oggi a lavorarci seriamente e potrei aver aperto L.O.calc da schermata di L.O. senza pertanto evidenziare il malfunzionamento.
Suggerimenti?
grazie

Ritratto di james2221
james2221
(Junior)
Offline
Junior
Iscritto: 10/09/2012
Messaggi: 7

ok, ho risolto, ma francamente non saprei dove era il bug. Dunque: disinstallato e reinstallato L.O. e i file di configurazione, disabilitato tutti i repository abilitando solo il DVD, reinstallato L.O., riabilitato i repository di prima e aggiornato. Non per dilungarmi, ma mi è rimasta una particolarità inspiegabile: nel menu di Mageia >tutte le applicazioni > ufficio >libre office>ecc ci sono write, base, impress ecc ma non è elencato L.O.calc. Ho provato a installarlo separatamente ma mi dice che è già a posto. Comunque tutto bene ugualmente, lo faccio partire da lanciatore sul pannello
grazie a tutti

devo scrivere risolto anche se non è ben chiaro come ??
ciao

Ritratto di killer1987
killer1987
(Webmaster)
Offline
Webmaster
Iscritto: 02/05/2011
Messaggi: 671

l'ho messo io. hai comunque spiegato la procedura che hai seguito, quindi può tornare utile anche ad altri utenti in futuro.

ciao
Marcello

Alé Mageia, C'mon Mageia!!! SAMSUNG RC530, Nvidia GM5400, stamp HP Laserjet 1018, scanner Epson Perfection 3490